Apple fixes AirPort flaw

Apple has patched a flaw in AirPort Extreme that was first revealed last November.

The fix is available for Mac OS X and OS X server versions 10.4.8. It prevents attacks on a wireless network that may cause system crashes.

The issue was first reported nearly two months ago as part of the Month of Kernel Bugs (MoKB) project.

The flaw affects the Core Duo version of Mac mini, MacBook and MacBook Pro systems equipped with wireless, according to an Apple advisory.

An attack may cause an out-of-bounds memory read while handling wireless frames if a hacker sends a specially-crafted frame to a targeted system.

LMH, a former hacker who spearheaded MoKB, is now in the midst of the Month of Apple Bugs project, which he has defended as necessary to bring attention to Apple security.

Experts have repeatedly said that OS X – as well as other alternative web browsers like Mozilla’s Firefox – will increasingly be targeted by attackers.

Click here to email Online Editor Frank Washkuch Jr.

Sign up to our newsletters