Users of version 7 of Adobe Reader and Acrobat will have to wait until late May to receive a patch to repair five critical vulnerabilities that have already been fixed in version 8, the company announced on Wednesday.

Users still running Adobe 7.0.9 and earlier versions should upgrade to the latest edition - 8.1.2 - of the popular PDF file-reading software, the company said in an advisory today.

Alternatively, those users still running version 7 - a real option considering many businesses are lax in their updating of such programs - can opt for a workaround. Details of the manual fix were described in the advisory, but basically it amounts to disabling JavaScript.

Almost two weeks ago, Adobe plugged a number of holes that could lead to attackers installing malicious code on users' machines.

The latest update can be found here.

Tags: Patch Management Vulnerabilities & Flaws Emerging Threats