Apple has updated Safari to version 4.0.3 to fix stability and compatibility issues.

Apple claimed that the products affected are product security, Safari 4 (Windows), Safari 4 (Mac OS X 10.5) and Safari 4 (Mac OS X 10.4).

The vulnerabilities include a fix for Safari promoting malicious websites on its at-a-glance ‘Top Sites' view, unwanted data leakage, and an exploit that could be used by hackers to run malicious code on the users computer.

Graham Cluley, senior technology consultant at Sophos, claimed that regardless of whether you run Safari on Windows XP or Vista, it is important to apply the patches as two of the security patches only apply to the version of Apple's browser that runs on Microsoft's operating system.

“Clearly it's very important that Safari users update their systems as soon as possible,” said Cluley.