Drupal issues patch for 'moderately critical' by-pass vulnerability

News by Robert Abel

Drupal core released a patch for a moderately critical vulnerability in third-party libraries that could allow the by-passing of protection of Phar Steam Wrapper Interceptor.

Drupal core released a patch for a moderately critical vulnerability in third-party libraries that could allow the by-passing of protection of Phar Steam Wrapper Interceptor.

The vulnerability occurs when untrusted data is used to abuse the logic of the application, according to, TYPO3-PSA-2019-007: By-passing protection of Phar Stream Wrapper Interceptor.

"In order to intercept file invocations like file_exists or stat on compromised Phar archives the base name has to be determined and checked before allowing to be handled by PHP Phar stream handling," the report said, adding "the current implementation is vulnerable to path traversal leading to scenarios where the Phar archive to be assessed is not the actual (compromised) file."

Users are encouraged to upgrade to the latest version with those using Drupal 8.7 advised to update to Drupal 8.7.1, those using Drupal 8.6 or earlier advised to update to update to Drupal 8.6.16 and those using Drupal 7, update to Drupal 7.67.

This article was originally published on SC Media US.

Find this article useful?

Get more great articles like this in your inbox every lunchtime

Video and interviews

Interview - Everyone has an Achilles heel: The new security paradigm

How can we defend networks now that the perimeter has all but disappeared?
Brought to you in partnership with ExtraHop